Linux e SCSI: sempre à pancada!
Contribuído por npf em 20-11-01 12:32
do departamento consultorio
perguntas xpto :) escreve "Parece que Linux (neste caso RH7.1 ou MDK8) ainda não se dão bem com adaptadores SCSI.

-----
Estou a tentar instalar REDHAT 7.2 numa máquina com HD SCSI. Quando arranco do CD de linux, o kernel começa a ser carregado, vai para RAMDISK onde encontra uma imagem comprimida no bloco 0 e depois mostra "

crc: errorFreeing initrd memory: 2046k freed
EXT2-fs: unable to read superblock
cramfs: wrong magic
isofs_read_super: bread failed, dev=09:02, isoblknum=16, block=32
Kernel Panic: VFS: unable to mount root fs on 09:02

e bloqueia.
Como é que posso resolver o problema? Já reparei que não carrega drivers SCSI antes disto. Será daí o problema? E passar parametros ao LILO? Já experimentei "linux text root=/dev/sda1" mas não adiantou.

As nossas maquinas :)

 
gildot Login
Login:

Password:

Referências
  • Linux
  • Red Hat
  • Mais acerca perguntas
  • Também por npf
  • "Linux e SCSI: sempre à pancada!" | Login/Criar uma conta | 5 comentários | Procurar na discussão
    Filtro:
    ATENÇÃO: Os comentários são da exclusiva responsabilidade dos seus autores.
    Cana de pesca (Pontos:2)
    por jmce em 20-11-01 12:41 GMT (#1)
    (Utilizador Info) http://jmce.artenumerica.org/
    Será que a resposta anda por aqui?
    [ Responder | Pai ]
    XisPes (Pontos:1, Despropositado)
    por Gamito em 20-11-01 12:44 GMT (#2)
    (Utilizador Info)
    "Parece que Linux (neste caso RH7.1 ou MDK8) ainda não se dão bem com adaptadores SCSI"

    Quando Linux e SCSI não se derem bem, mais vale instalarmos XisPes :-)

    Mário Gamito
    "Make everything as simple as possible... but not simpler"
    Albert Einstein
    [ Responder | Pai ]
    Memoria (Pontos:2)
    por nmarques em 20-11-01 12:45 GMT (#3)
    (Utilizador Info) http://nmarques.xpto.org
    Esse problema já eu tive, e foi uma questão de remover o dimm de memória estragado e substituir... era exactamente igual... independentemente de não ter dispositivos SCSI (Por acaso existia uma Initio 9xxx, mas que nao estava a ser utilizada para nada), acontecia exactamente o mesmo.

    Normalmente não é boa politica culpar o software por problemas de hardware :)... As unicas controladoras SCSI e RAID que trabalhei foram Adaptec's AIC9xxx, Initio 9xxx e IBM ServeRAID, sempre tudo funcionou sem problemas de qualquer especie... isto já vai desde o Red Hat 6.2. O Suporte SCSI para Linux funciona e muito bem.
    Cumps,
    Nelson

    --------------------------------------------
    If there is such a thing as too much power...
    I've not discovered it...
    [ Responder | Pai ]
    boot pelo cd (Pontos:1)
    por paulino em 20-11-01 13:27 GMT (#4)
    (Utilizador Info)
    Já experimentou usar os atiquados "disquetes" com a imagem do instalador? Ou usar um cdrom IDE. Pode ser que o cdrom scsi ou a bios da controladora não se de bem com cd "bootavel".
    [ Responder | Pai ]
    Não me parece ... (Pontos:1)
    por faustino em 20-11-01 14:55 GMT (#5)
    (Utilizador Info)
    que a culpa seja do facto de ser SCSI, pois já instalei através de CDROM SCSI Plextor em placas 2940uw da adaptec e tekram DC390U2W e nunca tive problemas, deves ter algum hardware danificado, memória, etc.
    Lembro-me que da primeira vez que instalei RH7.0 no meu comp. que tem a tekram levei 18 minutos a por o bicho pronto a funcionar(foi ligar o comp,por o cd, fazer boot do cd, configurar e esperar), com o winshit 98 levei quase dois dias a tentar instalar e acabei por usar linux para criar disquetes de arranque com os drivers para a placa e cd rom para o instalar.
    [ Responder | Pai ]